Woodturner's Resource
Woodturner's Resource  
  • Featured Artist    • Websites   Support Wr
Tutorials, Projects & Tips   • Event Calendar   • Tool and Book Store
  Home Page Forum HelpSearch Map TPT Resources LoginRegister
 
Page Index Toggle Pages: 1
Send Topic Print
PM 3520C display (Read 230 times)
 
Glenn Jacobs
WR Addict
*****
Offline


JC L&S

Posts: 1,913

North DFW, Texas, USA
North DFW
Texas
USA

Gender: male

Powermatic 3520C
PM 3520C display
Jul 23rd, 2021 at 3:28pm
 
I bought my PM last year. It ran fine, but with a high pitched whine until last week. Then it started running quietly and the display started showing upper right leg only in all spaces no matter the rpm. Any suggestions as to what is wrong?  I would like to know before I call tech support.  Other than the display, it runs fine.

Glenn J.
Back to top
  
Glenn+J  
IP Logged
 
Steven Sabinash
WR Noob
Offline


WR Rocks!

Posts: 8

Clarksville, Tennessee, USA
Clarksville
Tennessee
USA

Gender: male
Re: PM 3520C display
Reply #1 - Jul 25th, 2021 at 5:59pm
 
I had the same high pitched whine on my 3520C when it was. The noise was coming from the belt. It didn't matter how I tensioned the belt it continued. I used a stick of carnuaba wax and lightly dressed the belt and I haven't have a squeak since.
Back to top
  
 
IP Logged
 
Glenn Jacobs
WR Addict
*****
Offline


JC L&S

Posts: 1,913

North DFW, Texas, USA
North DFW
Texas
USA

Gender: male

Powermatic 3520C
Re: PM 3520C display
Reply #2 - Jul 26th, 2021 at 10:58am
 
What I'm concerned with is the display. It was working, now it only shows one quadrant of each block.

The manual does not address this problem.

Glenn J.
Back to top
  
Glenn+J  
IP Logged
 
Robert Hayward
WR Addict
*****
Offline


WR Rocks!

Posts: 681

Tampa area, Florida, USA
Tampa area
Florida
USA

Gender: male

3520b
Re: PM 3520C display
Reply #3 - Jul 26th, 2021 at 11:45am
 
Have you checked the RPM pickup magnet? That is, did it come loose?
Back to top
  
 
IP Logged
 
John Grace
WR Addict
*****
Offline


Everyone needs a good
wingman...

Posts: 1,228

Bel Air, Maryland, USA
Bel Air
Maryland
USA

Re: PM 3520C display
Reply #4 - Jul 27th, 2021 at 11:18am
 
Glenn Jacobs wrote on Jul 26th, 2021 at 10:58am:
What I'm concerned with is the display. It was working, now it only shows one quadrant of each block.


Certainly not an expert in such things but it sounds like the LED itself is bad...good luck.
Back to top
  

“If history were taught in the form of stories, it would never be forgotten.”  Kipling
 
IP Logged
 
Glenn Jacobs
WR Addict
*****
Offline


JC L&S

Posts: 1,913

North DFW, Texas, USA
North DFW
Texas
USA

Gender: male

Powermatic 3520C
Re: PM 3520C display
Reply #5 - Jul 27th, 2021 at 12:30pm
 
Robert Hayward wrote on Jul 26th, 2021 at 11:45am:
Have you checked the RPM pickup magnet? That is, did it come loose?


Where is it?

Glenn J.
Back to top
  
Glenn+J  
IP Logged
 
Robert Hayward
WR Addict
*****
Offline


WR Rocks!

Posts: 681

Tampa area, Florida, USA
Tampa area
Florida
USA

Gender: male

3520b
Re: PM 3520C display
Reply #6 - Jul 27th, 2021 at 8:51pm
 
Look at the parts page of your manual. It should be attached to the spindle closest to the handwheel inside the headstock. I have a B model so mine may not be the same. In the attached picture the large circle is the entire thing. The small circle is the sensor. Lousy picture but the best I could get with a flashlight and my phone.

If the pickup is in place you most likely have a bad display, as John says.
Back to top
  
 
IP Logged
 
Glenn Jacobs
WR Addict
*****
Offline


JC L&S

Posts: 1,913

North DFW, Texas, USA
North DFW
Texas
USA

Gender: male

Powermatic 3520C
Re: PM 3520C display
Reply #7 - Jul 29th, 2021 at 11:40am
 
Thanks, will look at this afternoon.

Glenn J.
Back to top
  
Glenn+J  
IP Logged
 
Glenn Jacobs
WR Addict
*****
Offline


JC L&S

Posts: 1,913

North DFW, Texas, USA
North DFW
Texas
USA

Gender: male

Powermatic 3520C
Re: PM 3520C display
Reply #8 - Aug 15th, 2021 at 7:06am
 
Talked with Tech at Powermatic about this problem. they walked me through some steps to determine the cause, then sent me both the pickup and the encoder to replace the defective ones. Now lets hope I have the knowledge to replace them without messing anything else up.

I would like to give a round of praise to Tony and James at JPW for their grasp of the situation and stepping me through what to look for to resolve the problem. Thumbs Up Thumbs Up Thumbs Up Thumbs Up


Glenn J.
Back to top
  
Glenn+J  
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print